summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTheJackiMonster2020-04-23 01:44:54 +0200
committerTheJackiMonster2020-04-23 01:44:54 +0200
commit8429987776b0c11374626ef7bd62a0050fb31354 (patch)
treeaf3e551b48bb33dd6c34337cb5bc1652666693cf /PKGBUILD
downloadaur-8429987776b0c11374626ef7bd62a0050fb31354.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c291107c373e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Tobias Frisch <thejackimonster@gmail.com>
+
+_pkgname=pep-engine
+pkgname=$_pkgname-hg
+pkgver=r4205.f75e9274551f
+pkgrel=1
+pkgdesc="A Free Software library for automatic key management and encryption of messages."
+arch=('x86_64' 'i686')
+url='https://pep.software'
+license=('GPL3')
+makedepends=('mercurial' 'asn1c' 'make' 'yml2')
+depends=('libetpan-fdik-git' 'gpgme' 'sqlite')
+provides=('pep-engine')
+source=("hg+https://pep.foundation/dev/repos/pEpEngine")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/pEpEngine"
+
+ printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
+}
+
+build() {
+ cd "$srcdir/pEpEngine"
+
+ echo "PREFIX=$pkgdir/usr" > 'local.conf'
+ echo "PER_MACHINE_DIRECTORY=$pkgdir/usr/share/pEp" >> 'local.conf'
+ echo "YML2_PATH=/usr/bin" >> 'local.conf'
+
+ make all
+ make db
+}
+
+package() {
+ cd "$srcdir/pEpEngine"
+
+ make install
+}
+