summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSwift Geek2012-03-17 23:00:12 +0000
committerThomas Dziedzic2012-03-17 23:00:12 +0000
commit084b3287487a4d3e9a1e4599ba0552304ca6ee70 (patch)
tree28bfcb659f1c1ca487c941e21b39ac8687293687 /PKGBUILD
downloadaur-084b3287487a4d3e9a1e4599ba0552304ca6ee70.tar.gz
Import from pkgbuild.com service
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c4a92df2c17c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Contributor: Christian Sturm <reezer@reezer.org>
+# Contributor: Anton Bazhenov <anton.bazhenov at gmail>
+# Contributor: Francois Charette <firmicus@gmx.net>
+
+pkgname=perl-alien-wxwidgets
+_pkgname=Alien-wxWidgets
+pkgver=0.56
+pkgrel=1
+pkgdesc="Building, finding and using wxWidgets binaries"
+arch=('any')
+url="https://metacpan.org/release/Alien-wxWidgets"
+license=('GPL' 'PerlArtistic')
+depends=('perl')
+options=('!emptydirs')
+source=(http://cpan.metacpan.org/authors/id/M/MD/MDOOTSON/${_pkgname}-$pkgver.tar.gz)
+md5sums=('40d437f4cd3719470d5b2a78769b3902')
+
+build() {
+ cd $srcdir/${_pkgname}-$pkgver
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+ make DESTDIR=$pkgdir install || return 1
+ find $pkgdir -name perllocal.pod -delete
+ find $pkgdir -name .packlist -delete
+}