summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSwift Geek2015-01-05 00:00:07 +0000
committerKyle Keen2015-01-05 00:00:07 +0000
commita885e440957f503f3292241c23fbb7f1e9e42949 (patch)
treed3fa2945bfd0714fd2446402ec25c41d9e605509 /PKGBUILD
parent196a55b555e4babe932308ec90e000de5b291f95 (diff)
downloadaur-a885e440957f503f3292241c23fbb7f1e9e42949.tar.gz
Import from pkgbuild.com service
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 23 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 51724c6a8d20..a16aa6928330 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Swift Geek <swiftgeek «at» gmail.com>
# Contributor: Nick Østergaard <oe.nick at gmail dot com>
# Contributor: John D Jones III (jnbek) <jnbek1972 at gmail dot com>
-
+# Contributor: not_anonymous <nmlibertarian@gmail.com>
pkgname=perl-alien-wxwidgets
_cpan_name=Alien-wxWidgets
@@ -11,11 +11,16 @@ pkgdesc="building, finding and using wxWidgets binaries"
arch=('any')
url="http://search.cpan.org/dist/${_cpan_name}"
license=('GPL' 'PerlArtistic')
-depends=('perl>=5.10.0' 'wxgtk2.8' 'perl-module-pluggable') # Install perl-module-pluggable from AUR
+depends=('perl>=5.10.0' 'wxgtk' 'perl-module-pluggable') # Install perl-module-pluggable from AUR
makedepends=()
options=(!emptydirs)
-source=("http://www.cpan.org/modules/by-module/${_cpan_name%%-*}/${_cpan_name}-${pkgver}.tar.gz")
-md5sums=('219a4f572d24eaa98c3dc2d118c5d9f0')
+source=("http://www.cpan.org/modules/by-module/${_cpan_name%%-*}/${_cpan_name}-${pkgver}.tar.gz"
+ 'https://rt.cpan.org/Ticket/Attachment/1400329/743429/wx-config-version-and-env.patch'
+ 'https://rt.cpan.org/Ticket/Attachment/1239555/655334/Alien-wxWidgets-0.64-returnor.patch'
+ )
+md5sums=('219a4f572d24eaa98c3dc2d118c5d9f0'
+ '1d21142e0a60bec1a4fab11dc545f955'
+ '0011e91d60a7a669426341687cb6a5e2')
prepare() {
export _src_dir="${_cpan_name}-${pkgver}"
@@ -25,12 +30,21 @@ prepare() {
PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
MODULEBUILDRC=/dev/null
warning "If build stage tries to pull and compile WX - interrupt as resulting package wont work"
- warning "If package contains gtk2_3_0_0_uni_gcc_3_4.pm it is an improper package - do not attempt to install it - report in comments instead"
+# warning "If package contains gtk2_3_0_0_uni_gcc_3_4.pm it is an improper package - do not attempt to install it - report in comments instead"
- # HAX HAX HAX - hax first in PATH to replace /usr/bin
- mkdir ${srcdir}/hax
- ln -s /usr/bin/wx-config-2.8 ${srcdir}/hax/wx-config
- export PATH="${srcdir}/hax:${PATH}"
+# HAX HAX HAX - hax first in PATH to replace /usr/bin
+# Uncomment lines below to compile against wxgtk2.8
+# mkdir ${srcdir}/hax
+# ln -s /usr/bin/wx-config-2.8 ${srcdir}/hax/wx-config
+# export PATH="${srcdir}/hax:${PATH}"
+### We are now patching issues, so compilation against 3.x is possible
+# https://rt.cpan.org/Public/Bug/Display.html?id=94367
+# https://rt.cpan.org/Public/Bug/Display.html?id=87202
+ {
+ cd "$_src_dir"
+ patch < ${srcdir}/wx-config-version-and-env.patch
+ patch ./lib/Alien/wxWidgets/Utility.pm < ${srcdir}/Alien-wxWidgets-0.64-returnor.patch
+ }
}
build() {