summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbrent s.2017-09-16 14:30:00 -0400
committerbrent s.2017-09-16 14:30:00 -0400
commit2b186f53c39b7f8f70b3e490d0d75c2e0e5d7c73 (patch)
tree30d0663d55349faf72572381fff84203d4aa6acc /PKGBUILD
downloadaur-2b186f53c39b7f8f70b3e490d0d75c2e0e5d7c73.tar.gz
initial commit; setting up .gitignores and skeleton PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..00f45fb5bc07
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: brent s. <bts[at]square-r00t[dot]net>
+validpgpkeys=('748231EBCBD808A14F5E85D28C004C2F93481F6B')
+# Bug reports can be filed at https://bugs.square-r00t.net/index.php?project=3
+# News updates for packages can be followed at https://devblog.square-r00t.net
+pkgname=perl-app-asciio
+pkgver=1.51.3
+pkgrel=1
+pkgdesc="Build ASCII diagrams"
+arch=( 'i686' 'x86_64' )
+url="http://search.cpan.org/dist/App-Asciio/lib/App/Asciio.pm"
+license=( 'GPL' 'PERLARTISTIC' )
+depends=( 'perl' )
+_pkgname=perl-app-asciio
+install=
+changelog=
+noextract=()
+source=("http://search.cpan.org/CPAN/authors/id/N/NK/NKH/App-Asciio-1.51.3.tar.gz"
+ "App-Asciio-1.51.3.tar.gz.sig")
+sha512sums=('49c3f685fbb33a7bbe737107ca6e68b4f0ea7b0757601ada6dd5fce7f7dfc232f1ff178d55b5fe33fc4718290ec771454bb61eda64b85e83899b97b40b641948'
+ 'SKIP')
+build() {
+ cd "${srcdir}/${_pkgname}/src"
+ make prefix=${pkgdir}/usr
+}
+package() {
+ install -D -m755 ${srcdir}/${_pkgname}/src/${_pkgname} ${pkgdir}/usr/bin/${_pkgname}
+ install -D -m644 ${srcdir}/${_pkgname}/docs/README.html.en ${pkgdir}/usr/share/doc/${_pkgname}/README.html
+}