summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorThiago L. A. Miller2018-09-01 04:14:26 -0300
committerThiago L. A. Miller2018-09-01 04:14:26 -0300
commit0acf21b5bfc51081605d60f4528c98d5e90cfaf5 (patch)
tree169346c2a3f9608064f1da6b23a9b0058f8e3128 /PKGBUILD
parent4975eb964539134bc38e7310f2e8ebe84387f829 (diff)
downloadaur-0acf21b5bfc51081605d60f4528c98d5e90cfaf5.tar.gz
Back to life! $Astro::SunTime::VERSION = 0.06
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 14 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3e18e1f0d2c9..c197df5745d7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
+# Maintainer: Thiago L. A. Miller <thiago_leisrael@hotmail.com>
# Contributor: John D Jones III AKA jnbek <jnbek1972 -_AT_- g m a i l -_Dot_- com>
-# Generator : CPANPLUS::Dist::Arch 1.32
-pkgname='perl-astro-suntime'
-pkgver='0.01'
-pkgrel='1'
+_distname=Astro-SunTime
+pkgname=perl-astro-suntime
+pkgver=0.06
+pkgrel=1
pkgdesc="Get Sun Rise and Set Times for any location on the globe"
arch=('any')
license=('PerlArtistic' 'GPL')
-options=('!emptydirs')
-depends=('perl-time-parsedate')
+depends=('perl>=0')
makedepends=()
-url='https://metacpan.org/release/Astro-SunTime'
-source=('http://search.cpan.org/CPAN/authors/id/R/RO/ROBF/Astro-SunTime-0.01.tar.gz')
-md5sums=('4657927a49604494bfaaa153663b90b9')
-sha512sums=('be14637e9f2a1f310f645f9e2e9f2cda484ac63a8e7acfa7d02cb312c4d5f8b21bcf6da2ea43d05152b3797c3c0f623ec65f649b70975b8c2eb99a8b86ca5213')
-_distdir="Astro-SunTime-0.01"
+checkdepends=('perl-time-parsedate')
+options=('!emptydirs')
+url="https://metacpan.org/release/$_distname"
+source=("http://search.cpan.org/CPAN/authors/id/R/RO/ROBF/$_distname-$pkgver.tar.gz")
+md5sums=('42cb8c94de8a111ed652196925c22a45')
build() {
( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
@@ -23,23 +23,22 @@ build() {
PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
MODULEBUILDRC=/dev/null
- cd "$srcdir/$_distdir"
+ cd "$_distname-$pkgver"
/usr/bin/perl Makefile.PL
make
)
}
check() {
- cd "$srcdir/$_distdir"
+ cd "$_distname-$pkgver"
( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
make test
)
}
package() {
- cd "$srcdir/$_distdir"
+ cd "$_distname-$pkgver"
make install
-
find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}