summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohn D Jones III2015-06-16 14:05:33 -0600
committerJohn D Jones III2015-06-16 14:05:33 -0600
commit0ef5080ef2c2e4485289e5d6fdb951c5e55c8976 (patch)
tree853aea52d4e6a0bbb2f2b18d55c95715033300f5 /PKGBUILD
downloadaur-0ef5080ef2c2e4485289e5d6fdb951c5e55c8976.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..164bf4b50308
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Contributor: John D Jones III <jnbek1972 -_AT_- g m a i l -_Dot_- com>
+# Generator : CPANPLUS::Dist::Arch 1.29
+
+pkgname='perl-astro-suntime'
+pkgver='0.01'
+pkgrel='1'
+pkgdesc="Get Sun Rise and Set Times for any location on the globe"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl-time-modules')
+makedepends=()
+url='http://search.mcpan.org/dist/Astro-SunTime'
+source=('http://search.mcpan.org/CPAN/authors/id/R/RO/ROBF/Astro-SunTime-0.01.tar.gz')
+md5sums=('4657927a49604494bfaaa153663b90b9')
+sha512sums=('be14637e9f2a1f310f645f9e2e9f2cda484ac63a8e7acfa7d02cb312c4d5f8b21bcf6da2ea43d05152b3797c3c0f623ec65f649b70975b8c2eb99a8b86ca5213')
+_distdir="Astro-SunTime-0.01"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: