summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTroy Will2018-10-21 18:34:41 -0700
committerTroy Will2018-10-21 18:34:41 -0700
commit0177d5c200bf36cb76bb64c0e5b96e2217ed55d6 (patch)
tree1a8aa3bea1dfd9d23a8c9172fc1ac627f6413bd0 /PKGBUILD
downloadaur-perl-astro-telescope.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d24dec79d318
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Contributor: Troy Will <.com .gmail AT troydwill>
+pkgname=perl-astro-telescope
+pkgver=0.71
+pkgrel=1
+pkgdesc='Astro::Telescope - class for obtaining telescope information'
+_dist=Astro-Telescope
+_author=T/TJ/TJENNESS
+arch=('any')
+url="https://metacpan.org/release/$_dist"
+license=('GPL' 'PerlArtistic')
+depends=(perl)
+options=('!emptydirs' purge)
+source=("https://cpan.metacpan.org/authors/id/$_author/$_dist-$pkgver.tar.gz")
+md5sums=(b1bd791667a18be7621b2aa5d6534a38)
+
+build() {
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 MODULEBUILDRC=/dev/null
+ /usr/bin/perl Build.PL
+ ./Build
+}
+
+check() {
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1
+ ./Build test
+}
+
+package() {
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ ./Build install --installdirs=vendor --destdir="$pkgdir"
+}