summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohn D Jones III2015-06-16 14:23:51 -0600
committerJohn D Jones III2015-06-16 14:23:51 -0600
commitb7ce1662b8fd7236e52f3e11d429a5c830ca11aa (patch)
treea31dbac9a2e1a2f1ed17af3345e989033242e960 /PKGBUILD
downloadaur-b7ce1662b8fd7236e52f3e11d429a5c830ca11aa.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..750dfb9deb66
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Contributor: John D Jones III <j[nospace]n[nospace]b[nospace]e[nospace]k[nospace]1972 -_AT_- the domain name google offers a mail service at ending in dot com>
+# Generator : CPANPLUS::Dist::Arch 1.25
+
+pkgname='perl-class'
+pkgver='1.00'
+pkgrel='1'
+pkgdesc="Alias for __PACKAGE__"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl')
+makedepends=()
+url='http://search.cpan.org/dist/CLASS'
+source=('http://search.cpan.org/CPAN/authors/id/M/MS/MSCHWERN/CLASS-1.00.tar.gz')
+md5sums=('834b888b9c8a936b12de2c168798b618')
+sha512sums=('6e6f782cc7d86e5a5e5f052fbc598374451ce0600a238480275c462f1782b70b68e0b4cc968efa349bfdf1736d587b9f8d21b95361ad0a0f22bb46b324c08451')
+_distdir="CLASS-1.00"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: