summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorint2020-11-29 11:43:03 +0100
committerint2020-11-29 11:43:03 +0100
commit692806c67223cee51a98b07a16230dda90ab1b11 (patch)
tree27d898f82eff196a4bb1ff8cc5439599bb8a288c /PKGBUILD
parent89f2d35e4b9d8a8c468c0385060539dee05d8311 (diff)
downloadaur-perl-class-adapter.tar.gz
Version bump and new maintainer.
New maintainer, so some adaptions to PKGBUILD from me. The package description is slightly different and added this cpan2aur-bugfix, see https://rt.cpan.org/Public/Bug/Display.html?id=123153 for details.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD91
1 files changed, 43 insertions, 48 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 73fdf9c11129..edc21c65c8ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,55 +1,50 @@
-# Maintainer: Jon Ribeiro <contact@jonathas.com>
-pkgname=perl-class-adapter
-_realname=Class-Adapter
-pkgver=1.08
-pkgrel=1
-pkgdesc="Perl implementation of the \"Adapter\" Design Pattern"
-arch=(i686 x86_64)
-license=('perl')
-url="http://search.cpan.org/~adamk/Class-Adapter"
-options=(!emptydirs)
-
-depends=('perl>=5.10.1')
-makedepends=('perl')
-
-#provides=('Class-Adapter')
-provides=('class-adapter=1.08' 'Class::Adapter::Clear=1.08' 'perl-class-adapter-clear=1.08' 'Class::Adapter=1.08' 'perl-class-adapter=1.08' 'Class::Adapter::Builder=1.08' 'perl-class-adapter-builder=1.08')
+# Maintainer: int <int [ate] arcor [dot] de>
+# Generator : CPANPLUS::Dist::Arch 1.32
+
+pkgname='perl-class-adapter'
+pkgver='1.09'
+pkgrel='1'
+pkgdesc="Perl/CPAN Module Class::Adapter: Perl implementation of the \"Adapter\" Design Pattern"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl>=5.006')
+makedepends=()
+url='https://metacpan.org/release/Class-Adapter'
+source=("http://search.cpan.org/CPAN/authors/id/E/ET/ETHER/Class-Adapter-$pkgver.tar.gz")
+md5sums=('703c3d13e991f300ab2ed0a47931d6ab')
+sha512sums=('e6b7bde685683fa733e3002cf815aca6e298b2200a3fedbef93345284507023cdeed0cda4232c53d4dfd89239271a871db44616606d88ff5d03ac7c3e33a992a')
+_distdir="Class-Adapter-$pkgver"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
-source=('http://search.cpan.org/CPAN/authors/id/A/AD/ADAMK/Class-Adapter-1.08.tar.gz')
-md5sums=('4a1dbb281eac71f666d2eeccf4cc8b99')
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
package() {
- _expected_dir="${srcdir}/${_realname}-${pkgver}"
- if [ -d "$_expected_dir" ]; then
- cd "$_expected_dir"
- else
- _expected_dir="${srcdir}/$(bsdtar -t -f $(basename $source) | head -n1)"
- if [ -d "$_expected_dir" ]; then
- cd "$_expected_dir"
- else
- _makefile=$(find $srcdir -iname Makefile.PL)
- if [ ! -z "$_makefile" ]; then
- _expected_dir=$(dirname $_makefile)
- if [ -d "$_expected_dir" ]; then
- cd "$_expected_dir"
- else
- echo "ERROR unable to detect source directory"
- echo "--> this is often due to CPAN's lack of standard naming conventions"
- echo "--> it may be possible to fix this by adjusting the build function in the PKGBUILD"
- fi
- fi
- fi
- fi
- # install module in vendor directories.
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
- make || return 1
- make install DESTDIR=${pkgdir} || return 1
+ cd "$srcdir/$_distdir"
+ make install
- # remove perllocal.pod and .packlist
- find ${pkgdir} -name perllocal.pod -delete
- find ${pkgdir} -name .packlist -delete
+ find "$pkgdir" "(" -name .packlist -o -name perllocal.pod ")" -delete
}
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
# vim:set ts=2 sw=2 et:
-
-