summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorArcher7772015-07-01 17:46:47 +0500
committerArcher7772015-07-01 17:46:47 +0500
commitef108346916fb02e0cce638d687a452fd196f110 (patch)
tree5064af92ed6963a1ea83497a3b63c271dd728518 /PKGBUILD
downloadaur-ef108346916fb02e0cce638d687a452fd196f110.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d8ae5a3a5695
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Contributor: Archer777 <NAME at gmx dot com>
+
+_realname=Compiler-Lexer
+pkgname=perl-compiler-lexer
+pkgver=0.22
+pkgrel=1
+pkgdesc="Lexical Analyzer for Perl5"
+arch=('i686' 'x86_64')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl>=5.8.1')
+makedepends=('perl-module-build' 'perl-module-build-xsutil')
+url='http://search.cpan.org/dist/Compiler-Lexer'
+source=("https://cpan.metacpan.org/authors/id/G/GO/GOCCY/${_realname}-${pkgver}.tar.gz")
+md5sums=('2cb3b6886e75ab1db91757553b1bf83a')
+
+build() {
+ cd "${_realname}-${pkgver}"
+ perl Build.PL --installdirs=vendor
+ ./Build
+}
+
+check() {
+ cd "${_realname}-${pkgver}"
+ ./Build test
+}
+
+package() {
+ cd "${_realname}-${pkgver}"
+ ./Build install --destdir="${pkgdir}"
+}