summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhillip Smith2015-06-02 11:31:44 +1000
committerPhillip Smith2015-06-02 11:31:44 +1000
commit4a2c2d429f79e26e35a1f6ea69c5fa8ff0f7d7a8 (patch)
tree5b04da9ed944a0a3c33c0ff59f493372ef47356c /PKGBUILD
downloadaur-4a2c2d429f79e26e35a1f6ea69c5fa8ff0f7d7a8.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..413b69fe39d0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Phillip Smith <fukawi2@NO-SPAM.gmail.com>
+# Contributor: TDY <tdy@gmx.com>
+# Contributor: Max Nemeth <max.nemeth@gmail.com>
+
+### I AM ONLY THE PACKAGER, NOT THE DEVELOPER
+### Please ask support questions about this software in one of:
+### 1) The AUR comments; OR
+### 2) Upstream forums/maillist etc; OR
+### 3) The ArchLinux forums
+### I do not always know enough about the software itself, or don't have the
+### time to promptly respond to direct emails.
+### If you have found a problem with the package/PKGBUILD (as opposed to
+### the software) then please do email me or post an AUR comment.
+
+pkgname=perl-config-inifiles
+pkgver=2.83
+pkgrel=1
+pkgdesc="A Perl module for reading .ini-style configuration files"
+arch=('any')
+url="http://search.cpan.org/dist/Config-IniFiles/"
+license=('GPL' 'PerlArtistic')
+depends=('perl' 'perl-list-moreutils')
+options=('!emptydirs')
+source=("http://search.cpan.org/CPAN/authors/id/S/SH/SHLOMIF/Config-IniFiles-$pkgver.tar.gz")
+md5sums=('c34156374d3842289e537aaafa7b937f')
+
+build() {
+ cd "$srcdir"/Config-IniFiles-$pkgver
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+package() {
+ cd "$srcdir"/Config-IniFiles-$pkgver
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et: