summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorZhuoyun Wei2018-03-30 20:50:19 +0800
committerZhuoyun Wei2018-03-30 20:50:19 +0800
commit79622d79c9e41cfa75e7b6ce331dfd161212c3e7 (patch)
tree850dcc0382626d23202f531f74b559233b43515b /PKGBUILD
downloadaur-79622d79c9e41cfa75e7b6ce331dfd161212c3e7.tar.gz
1.007
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..50148b18be34
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Zhuoyun Wei <wzyboy@wzyboy.org>
+
+pkgname=perl-config-onion
+_dist=Config-Onion
+pkgver=1.007
+pkgrel=1
+pkgdesc="Config::Onion - Layered configuration, because configs are like ogres"
+arch=('any')
+url="https://github.com/dsheroh/Config-Onion"
+license=('GPL' 'PerlArtistic')
+depends=('perl')
+options=('!emptydirs')
+source=("http://search.cpan.org/CPAN/authors/id/D/DS/DSHEROH/Config-Onion-${pkgver}.tar.gz")
+sha256sums=('327fddf68e138b2469e5a2bae37c733f87ca84caf61e1cfaa949be3d950da8af')
+
+build() {
+ cd "$srcdir"/${_dist}-$pkgver
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+package() {
+ cd "$srcdir"/${_dist}-$pkgver
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name '.packlist' -delete
+ find "$pkgdir" -name '*.pod' -delete
+}