summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJason Ryan2015-07-08 20:16:42 +1200
committerJason Ryan2015-07-08 20:16:42 +1200
commitf8e1903a74a9ca24780ced1dfd444ecb5df626e6 (patch)
treee387a59fb2e0242c1405f5817f1bef9cd40689ca /PKGBUILD
downloadaur-f8e1903a74a9ca24780ced1dfd444ecb5df626e6.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e489dd2c30f9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: jason ryan <jasonwryan@gmail.com>
+# Contributor: Drathir <drathir87@gmail.com>
+
+pkgname='perl-cryptx'
+_cpanname='CryptX'
+pkgver='0.024'
+pkgrel='1'
+pkgdesc="Crypto toolkit (self-contained no external libraries needed)"
+arch=('i686' 'x86_64')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl-json>=2.01' 'perl>=5.06')
+makedepends=('perl-module-build')
+url='https://metacpan.org/release/CryptX'
+source=('https://cpan.metacpan.org/authors/id/M/MI/MIK/CryptX-0.024.tar.gz')
+md5sums=('1847e5f78d58497965ac83331183b418')
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/${_cpanname}-${pkgver}"
+ /usr/bin/perl Build.PL
+ /usr/bin/perl Build
+ )
+}
+
+check() {
+ cd "$srcdir/${_cpanname}-${pkgver}"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ /usr/bin/perl Build test
+ )
+}
+
+package() {
+ cd "$srcdir/${_cpanname}-${pkgver}"
+ /usr/bin/perl Build install
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# vim:set ts=2 sw=2 et: