summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAnton Leontiev2014-06-11 15:09:56 +0400
committerAnton Leontiev2015-02-15 07:48:23 +0300
commit306ee4601923f73552c561bf20c3d5ad6742519d (patch)
tree76fcb584c3a9b7e73e751e2b95c70564663a44b4 /PKGBUILD
parent2331637c996eb70f9612a1c193141369429a6d5b (diff)
downloadaur-306ee4601923f73552c561bf20c3d5ad6742519d.tar.gz
Updated to use template
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 19 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2c5f3a9854ac..ab003206a26e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,35 @@
+# CPAN Name : CSS::Squish
# Contributor: Anton Leontiev <bunder /at/ t-25.ru>
+# Generator : CPANPLUS::Dist::Arch 1.28
+
pkgname=perl-css-squish
pkgver=0.10
pkgrel=1
-pkgdesc="Perl module to compact many CSS files into one big file"
-arch=("any")
-url="http://search.cpan.org/dist/CSS-Squish/"
-license=("GPL" "PerlArtistic")
+pkgdesc='Perl package to compact many CSS files into one big file'
+arch=('any')
+url='http://search.cpan.org/dist/CSS-Squish'
+license=('PerlArtistic' 'GPL')
depends=("perl" "perl-uri")
checkdepends=("perl-test-longstring")
- # 'perl' provides 'perl-test-simple'
- # optionally 'perl-test-pod', 'perl-test-pod-coverage'
-
+ # 'perl' provides 'perl-test-simple'
+ # optionally 'perl-test-pod', 'perl-test-pod-coverage'
+source=(http://search.cpan.org/CPAN/authors/id/T/TS/TSIBLEY/CSS-Squish-0.10.tar.gz)
options=(!emptydirs)
-source=(http://search.cpan.org/CPAN/authors/id/T/TS/TSIBLEY/CSS-Squish-$pkgver.tar.gz)
-md5sums=("59f8e2c26a2a89418d2274e8ca44ae97")
+md5sums=('59f8e2c26a2a89418d2274e8ca44ae97')
build() {
- cd "$srcdir/CSS-Squish-$pkgver"
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
- make
+ cd CSS-Squish-0.10
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
}
check() {
- cd "$srcdir/CSS-Squish-$pkgver"
- make test
+ cd CSS-Squish-0.10
+ make test
}
package() {
- cd "$srcdir/CSS-Squish-$pkgver"
- make install DESTDIR="$pkgdir"
- find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+ cd CSS-Squish-0.10
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}