summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKevin Rauwolf2015-08-07 11:06:53 -0700
committerKevin Rauwolf2015-08-07 11:06:53 -0700
commit66d9cfafb67ca79e529cfd05dd8275f41532feb4 (patch)
tree87fadbfea4ba32ae0457d92bf09c027dc44808d4 /PKGBUILD
downloadaur-66d9cfafb67ca79e529cfd05dd8275f41532feb4.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD62
1 files changed, 62 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..62755219f596
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# vim:set ts=2 sw=2 et ft=sh tw=100: expandtab
+# Maintainer: Kevin Rauwolf <sweetpea-aur@tentacle.net>
+pkgname=perl-data-password
+pkgver=1.10
+pkgrel=1
+_author="R/RA/RAZINF"
+_perlmod="Data-Password"
+pkgdesc="Data::Password - Perl extension for assessing password quality"
+arch=('any')
+url="http://search.cpan.org/dist/Data-Password/"
+license=('PerlArtistic')
+depends=()
+makedepends=()
+options=(!emptydirs)
+source=("http://search.cpan.org/CPAN/authors/id/$_author/$_perlmod-$pkgver.tar.gz")
+
+build(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ # Setting these env variables overwrites any command-line-options we don't want...
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ # If using Makefile.PL
+ if [ -r Makefile.PL ]; then
+ /usr/bin/perl Makefile.PL
+ make
+ # If using Build.PL
+ elif [ -r Build.PL ]; then
+ /usr/bin/perl Build.PL
+ perl Build
+ fi
+}
+check(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ # If using Makefile.PL
+ if [ -r Makefile.PL ]; then
+ make test
+ # If using Build.PL
+ elif [ -r Build.PL ]; then
+ perl Build test
+ fi
+}
+package(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ # If using Makefile.PL
+ if [ -r Makefile.PL ]; then
+ make install
+ # If using Build.PL
+ elif [ -r Build.PL ]; then
+ perl Build install
+ fi
+
+ # remove perllocal.pod and .packlist
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+md5sums=('fc96097b398b9df2ec1b9b636cfebdc4')