summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKrzysztof (3ED) AS2015-07-02 10:03:49 +0200
committerKrzysztof (3ED) AS2015-07-02 10:03:49 +0200
commit9e36061bd6647c312e0da58a4bbcbe53490b0550 (patch)
tree9f0b70e997a79034d69c15afce5479e1bf3e5b08 /PKGBUILD
downloadaur-9e36061bd6647c312e0da58a4bbcbe53490b0550.tar.gz
moving files, making space for additional scripts, aur4 and other stuff
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4d2b772867ba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: 3ED <krzysztof1987 at gmail dot com>
+#
+pkgname=perl-defhash
+_lastauthor=P/PE/PERLANCAR
+_pkgname=DefHash
+pkgver=1.0.9
+pkgrel=1
+pkgdesc='Define things according to a specification, using hashes'
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl')
+url="https://metacpan.org/release/${_pkgname}"
+source=(https://cpan.metacpan.org/authors/id/${_lastauthor}/${_pkgname}-${pkgver}.tar.gz)
+sha512sums=('4dc6981d92380ec455b092fa159cf379fc569f83694a8682d0442e745fdf1ae16a8428419e8a75195a57fc49a0bf449d1a3f0419a060b06953be5f65f9aa9f22')
+
+build() {
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL="--skipdeps" \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ perl Makefile.PL
+ make
+}
+check() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ make test
+}
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ make install
+}