summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPiotr Rogoża2021-12-14 20:34:46 +0100
committerPiotr Rogoża2021-12-14 20:34:46 +0100
commit7f8a712a63ad2f9029650e15134959e96525a693 (patch)
tree23707307985fd2f2e6db505c320347eec8d82080 /PKGBUILD
parent55baef13475a35a7f06bc65ffcead5e218c8ec25 (diff)
downloadaur-perl-devel-smallprof.tar.gz
Replace http to https
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD60
1 files changed, 20 insertions, 40 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ec1bfdff3af7..812bb851e7be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,15 @@
-# Maintainer: Piotr Rogoża <rogoza dot piotr at gmail dot com>
-# Contributor: Piotr Rogoża <rogoza dot piotr at gmail dot com>
-# vim:set ts=2 sw=2 et ft=sh tw=100: expandtab
+# Maintainer: dracorp aka Piotr Rogoza <piotr.r.public at gmail.com>
_author=S/SA/SALVA
_perlmod=Devel-SmallProf
pkgname=perl-devel-smallprof
pkgver=2.02
-pkgrel=3
+pkgrel=4
pkgdesc="Devel::SmallProf - Per-line Perl profiler"
arch=('any')
-url="http://search.cpan.org/dist/Devel-SmallProf/"
+url="https://search.cpan.org/dist/Devel-SmallProf/"
license=('GPL' 'PerlArtistic')
-groups=()
-depends=('perl>=5.10.0')
+depends=(perl)
makedepends=()
optdepends=()
provides=()
@@ -21,51 +18,34 @@ replaces=()
backup=()
options=(!emptydirs)
install=
-source=("http://search.cpan.org/CPAN/authors/id/$_author/$_perlmod-$pkgver.tar.gz")
-noextract=()
+source=("https://search.cpan.org/CPAN/authors/id/$_author/$_perlmod-$pkgver.tar.gz")
+sha256sums=('8cd514166c66c44ffbe2d0728583032d602b5786ef3a0b7e575f733cc5bd8b08')
+unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps MODULEBUILDRC=/dev/null
build(){
cd "$srcdir"/$_perlmod-$pkgver
-
- # Setting these env variables overwrites any command-line-options we don't want...
- export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps \
- PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
- PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
- MODULEBUILDRC=/dev/null
-
- # If using Makefile.PL
- if [ -r Makefile.PL ]; then
- /usr/bin/perl Makefile.PL
+ if [ -f Makefile.PL ]; then
+ perl Makefile.PL
make
- # If using Build.PL
- elif [ -r Build.PL ]; then
- /usr/bin/perl Build.PL
- perl Build
+ else
+ perl Build.PL
+ ./Build
fi
}
check(){
cd "$srcdir"/$_perlmod-$pkgver
-
- # If using Makefile.PL
- if [ -r Makefile.PL ]; then
+ if [ -f Makefile.PL ]; then
make test
- # If using Build.PL
- elif [ -r Build.PL ]; then
- perl Build test
+ else
+ ./Build test
fi
}
package(){
cd "$srcdir"/$_perlmod-$pkgver
-
- # If using Makefile.PL
- if [ -r Makefile.PL ]; then
- make install
- # If using Build.PL
- elif [ -r Build.PL ]; then
- perl Build install
+ if [ -f Makefile.PL ]; then
+ make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
+ else
+ ./Build install --installdirs=vendor --destdir="$pkgdir"
fi
-
- # remove perllocal.pod and .packlist
- find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}
-md5sums=('498704ed1b888fc62b0c7092f8b590f5')