summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAnton Leontiev2022-06-27 17:34:07 +0300
committerAnton Leontiev2022-06-27 17:34:07 +0300
commit77b4488b74d1679b27433be0deac441f20e65538 (patch)
tree2aeb5acc9cb277e5adcc531eddd0d4604779ab12 /PKGBUILD
parente1c18f5f504b654b9ba9b7022685edf54b9c2a18 (diff)
downloadaur-perl-email-localdelivery.tar.gz
perl-email-localdelivery: Update to v1.201
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 20 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6aa414972545..3b992f3aa294 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,31 +3,39 @@
# Generator : CPANPLUS::Dist::Arch 1.32
pkgname=perl-email-localdelivery
-pkgver=1.200
-pkgrel=2
+pkgver=1.201
+pkgrel=1
pkgdesc='Perl module to deliver an email to a list of mailboxes'
arch=('any')
url='https://metacpan.org/release/Email-LocalDelivery'
license=('PerlArtistic' 'GPL')
depends=('perl>=5.8.8' 'perl-email-foldertype>=0.7' 'perl-email-simple>=1.998' 'perl-file-path-expand>=1.01')
checkdepends=('perl>=5.13.4' 'perl-capture-tiny')
-source=(http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/Email-LocalDelivery-1.200.tar.gz)
+source=(http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/Email-LocalDelivery-1.201.tar.gz)
options=(!emptydirs)
-md5sums=('6218c960f8f426b5c20a64b3fb7a6bf4')
+md5sums=('ce108d9b905719d811b290d08f98079e')
+
+sanitize() {
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 MODULEBUILDRC=/dev/null
+}
build() {
- cd Email-LocalDelivery-1.200
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
- make
+ cd Email-LocalDelivery-1.201
+ sanitize
+ /usr/bin/perl Makefile.PL INSTALLDIRS=vendor
+ make
}
check() {
- cd Email-LocalDelivery-1.200
- make test
+ cd Email-LocalDelivery-1.201
+ sanitize
+ make test
}
package() {
- cd Email-LocalDelivery-1.200
- make install DESTDIR="$pkgdir"
- find "$pkgdir" \( -name .packlist -o -name perllocal.pod \) -delete
+ cd Email-LocalDelivery-1.201
+ sanitize
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" \( -name .packlist -o -name perllocal.pod \) -delete
}