summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAmish2018-12-11 11:20:56 +0530
committerAmish2018-12-11 11:20:56 +0530
commit1f640c633c96eacc9ced69e6adc37d515e5cc8d8 (patch)
treebf2383c86dd0430b9146dbb933e753fa8a1aa2cd /PKGBUILD
parenta6da1bab353987de8da2557d589fee4f811c75a8 (diff)
downloadaur-1f640c633c96eacc9ced69e6adc37d515e5cc8d8.tar.gz
Follow perl package guidelines
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 19 insertions, 30 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 223a0a65a0bf..6f56c3421e23 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,51 +1,40 @@
# Maintainer: Amish <contact at via dot aur>
# Contributor: John D Jones III <j[nospace]n[nospace]b[nospace]e[nospace]k[nospace]1972 -_AT_- the domain name google offers a mail service at ending in dot com>
-# Generator : CPANPLUS::Dist::Arch 1.25
pkgname=perl-encode-detect
pkgver=1.01
-pkgrel=4
+pkgrel=5
pkgdesc="An Encode::Encoding subclass that detects the encoding of data"
-arch=('i686' 'x86_64')
-license=('PerlArtistic' 'GPL')
-options=('!emptydirs')
+_dist=Encode-Detect
+arch=('any')
+url="https://metacpan.org/release/${_dist}"
+license=('GPL' 'PerlArtistic')
depends=('perl')
makedepends=('perl-module-build')
-url='https://metacpan.org/pod/Encode::Detect'
-source=("https://cpan.metacpan.org/authors/id/J/JG/JGMYERS/Encode-Detect-${pkgver}.tar.gz")
+options=('!emptydirs' purge)
+source=("https://cpan.metacpan.org/authors/id/J/JG/JGMYERS/${_dist}-${pkgver}.tar.gz")
md5sums=('ee9faf55d7105c97b02b8ebe590819c7')
sha512sums=('cc9c81f716dcb61abb321abd84e4ebb95a674d9aa34c4265f58cace38f6d15ef4f2b8338190ae7d200672e047b795a30ce6155f9c1b1c424e25d962579b96224')
-_distdir="Encode-Detect-${pkgver}"
build() {
- ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
- PERL_AUTOINSTALL=--skipdeps \
- PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
- PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
- MODULEBUILDRC=/dev/null
-
- cd "$srcdir/$_distdir"
- /usr/bin/perl Makefile.PL
- make
- )
+ cd "${srcdir}/${_dist}-${pkgver}"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
+ /usr/bin/perl Makefile.PL
+ make
}
check() {
- cd "$srcdir/$_distdir"
- ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
- make test
- )
+ cd "${srcdir}/${_dist}-${pkgver}"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1
+ make test
}
package() {
- cd "$srcdir/$_distdir"
- make install
-
- find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+ cd "${srcdir}/${_dist}-${pkgver}"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ make install INSTALLDIRS=vendor DESTDIR="${pkgdir}"
}
-# Local Variables:
-# mode: shell-script
-# sh-basic-offset: 2
-# End:
# vim:set ts=2 sw=2 et: