summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGergan Penkov2015-08-02 11:35:02 +0200
committerGergan Penkov2015-08-02 11:35:02 +0200
commit757448e32a9fdcd9b5dd12e0331432e19a457a39 (patch)
tree67a67d25543c54bab0698ae986d6d5986d067e89 /PKGBUILD
downloadaur-757448e32a9fdcd9b5dd12e0331432e19a457a39.tar.gz
import from aur
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5930157d72e2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Maxwell Pray a.k.a. Synthead <synthead@gmail.com>
+# Contributor: Oliver Charles <oliver.g.charles@googlemail.com>
+
+pkgname=perl-fcgi-procmanager
+_cpanname="FCGI-ProcManager"
+pkgver='0.24'
+pkgrel='2'
+pkgdesc="Functions for managing FastCGI applications"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl>=5.5.0')
+url="http://search.cpan.org/~gbjk/$_cpanname"
+source=("http://search.cpan.org/CPAN/authors/id/B/BO/BOBTFISH/$_cpanname-$pkgver.tar.gz")
+md5sums=('0aa184b1e5339e0ad92f4c1439406304')
+
+
+# Function to change to the working directory and set
+# environment variables to override undesired options.
+prepareEnvironment() {
+ cd "$srcdir/$_cpanname-$pkgver"
+ export \
+ PERL_MM_USE_DEFAULT=1 \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+}
+
+build() {
+ prepareEnvironment
+ /usr/bin/perl Makefile.PL
+ make
+}
+
+check() {
+ prepareEnvironment
+ make test
+}
+
+package() {
+ prepareEnvironment
+ make install
+
+ # Remove "perllocal.pod" and ".packlist".
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}