summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoroli2015-06-12 21:54:52 +0200
committeroli2015-06-12 21:54:52 +0200
commitc473648b356e4a83eebec4c68080a5ca6cbed19d (patch)
tree54c265d4c92be42030706acac5d8c49028fc802d /PKGBUILD
downloadaur-perl-file-path.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..845fab12a15a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# This PKGBUILD was generated by cpan4pacman via CPANPLUS::Dist::Pacman
+# Maintainer: Jozef Riha <jose1711 at gmail dot com>
+
+pkgname=perl-file-path
+_cpanname=File-Path
+pkgver=2.09
+pkgrel=1
+pkgdesc="File path and name utilities"
+arch=('any')
+url="http://search.cpan.org/~DLAND/${_cpanname}"
+license=('GPL' 'PerlArtistic')
+depends=('perl')
+options=('!emptydirs')
+source=(http://www.cpan.org/authors/id/D/DL/DLAND/${_cpanname}-${pkgver}.tar.gz)
+md5sums=('423f5ead2727be5270f08a39df53be6c')
+
+build() {
+ cd $srcdir/${_cpanname}-${pkgver}
+ sed -i '/^auto_install/d' Makefile.PL
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+package() {
+ cd $srcdir/${_cpanname}-${pkgver}
+ make install DESTDIR=$pkgdir
+ find $pkgdir -name '.packlist' -delete
+ find $pkgdir -name '*.pod' -delete
+}