summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohn D Jones III2015-06-16 14:56:21 -0600
committerJohn D Jones III2015-06-16 14:56:21 -0600
commit4a9afbaca6f997481ea652424fa3eb61903148ab (patch)
treedaad7ae5ee07b03e0fd2f874b0c8b3f5858bffb1 /PKGBUILD
downloadaur-4a9afbaca6f997481ea652424fa3eb61903148ab.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..461f224b08e3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Contributor: John D Jones III <j[nospace]n[nospace]b[nospace]e[nospace]k[nospace]1972 -_AT_- the domain name google offers a mail service at ending in dot com>
+# Generator : CPANPLUS::Dist::Arch 1.25
+
+pkgname='perl-file-sync'
+pkgver='0.11'
+pkgrel='1'
+pkgdesc="Perl access to fsync() and sync() function calls"
+arch=('i686' 'x86_64')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl')
+makedepends=()
+url='http://search.cpan.org/dist/File-Sync'
+source=('http://search.cpan.org/CPAN/authors/id/B/BR/BRIANSKI/File-Sync-0.11.tar.gz')
+md5sums=('8bb0966ff3458699c02fde3d5c799824')
+sha512sums=('32816efa26185f2f26d5a469aa48baf1d22242ec620b663e5fbfdda3ffb360e6d2e1c7349989fa34b8cd84567b7a312863dba2be855cd6e696f67759ef4512b6')
+_distdir="File-Sync-0.11"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: