summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJonathan Liu2015-06-19 11:57:03 +1000
committerJonathan Liu2015-06-19 11:57:03 +1000
commitce9238b62c56dc52116d25ebff3c42dfb6d2d2d9 (patch)
tree48618a5766f1516f4826fa537d7132ad787b4eb1 /PKGBUILD
downloadaur-perl-grutatxt.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ec254aa937e8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Contributor: Jonathan Liu <net147@gmail.com>
+pkgname=perl-grutatxt
+_realpkgname=Grutatxt
+pkgver=2.0.16
+pkgrel=2
+pkgdesc="A plain text to HTML (and other formats) converter"
+arch=('i686' 'x86_64')
+url="http://triptico.com/software/grutatxt.html"
+license=('GPL2')
+depends=('perl')
+source=("http://triptico.com/download/grutatxt/$_realpkgname-$pkgver.tar.gz")
+md5sums=('c4ed46b4470442bfdea312679d188eb6')
+
+build() {
+ cd "$srcdir/$_realpkgname-$pkgver"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+package() {
+ cd "$srcdir/$_realpkgname-$pkgver"
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name perllocal.pod -delete
+ find "$pkgdir" -name .packlist -delete
+}
+
+# vim:set ts=2 sw=2 et: