summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohn D Jones III2015-06-16 15:01:14 -0600
committerJohn D Jones III2015-06-16 15:01:14 -0600
commit859af16d993dca0655c693af7efcdb579c47da6d (patch)
treeab0da3e82e005c62e0c16a8769e7fddbd1eef121 /PKGBUILD
downloadaur-859af16d993dca0655c693af7efcdb579c47da6d.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..af7dc6ebb66e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Contributor: John D Jones III <j[nospace]n[nospace]b[nospace]e[nospace]k[nospace]1972 -_AT_- the domain name google offers a mail service at ending in dot com>
+# Generator : CPANPLUS::Dist::Arch 1.25
+
+pkgname='perl-gtk2-webkit-mechanize'
+pkgver='0.01'
+pkgrel='1'
+pkgdesc="Mechanize like module using WebKit browser"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl-gtk2-webkit')
+makedepends=()
+url='http://search.cpan.org/dist/Gtk2-WebKit-Mechanize'
+source=('http://search.cpan.org/CPAN/authors/id/B/BO/BOSU/Gtk2-WebKit-Mechanize-0.01.tar.gz')
+md5sums=('42f275d630e97d26ccd156e725b934ff')
+sha512sums=('93cc11dfc0cd84d619688d579d3e0e1e98343256be69a8f6c977cf66fc036e3621c4e873d99116fd13f95877124216af609af7d6b527f5b5180dc19cb9ccbe3c')
+_distdir="Gtk2-WebKit-Mechanize-0.01"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: