summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsl1pkn072015-06-08 19:12:56 +0200
committersl1pkn072015-06-08 19:12:56 +0200
commit797ce9f70187f5ecc8b561ef360f78a5ad1bccad (patch)
tree5d35bfa9116cf0486f95a4fc0e0229a3b047fcd0 /PKGBUILD
downloadaur-797ce9f70187f5ecc8b561ef360f78a5ad1bccad.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f63f4ccb415e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+pkgname=perl-json-rpc
+pkgver=1.06
+pkgrel=1
+pkgdesc="Perl implementation of JSON-RPC 1.1 protocol"
+arch=('i686' 'x86_64')
+conflicts=('perl-json-rpc-legacy')
+url="http://search.cpan.org/dist/JSON-RPC/"
+license=('GPL' 'PerlArtistic')
+depends=('perl' 'perl-libwww' 'perl-plack' 'perl-router-simple' 'perl-json')
+checkdepends=('perl-test-pod')
+options=('!emptydirs' 'purge')
+source=("http://search.cpan.org/CPAN/authors/id/D/DM/DMAKI/JSON-RPC-${pkgver}.tar.gz")
+sha1sums=('d3288e5475c2fae5c7ed7fd5e547dd26a1fd07cd')
+
+build() {
+ cd "JSON-RPC-${pkgver}"
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 MODULEBUILDRC=/dev/null
+ /usr/bin/perl Build.PL
+ ./Build
+}
+
+
+check() {
+ cd "JSON-RPC-${pkgver}"
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1
+ ./Build test
+}
+
+package() {
+ cd "JSON-RPC-${pkgver}"
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ ./Build install installdirs=vendor destdir="${pkgdir}"
+ find "${pkgdir}" -name '.packlist' -o -name 'perllocal.pod' -delete
+}
+