summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWilhelm Schuster2020-10-28 18:01:01 +0100
committerWilhelm Schuster2020-10-28 18:01:01 +0100
commit818b1533c4781cc269ffe84593f3745ed05815e7 (patch)
treefbb919123d45789a8e430c41e8f1c3dca395690a /PKGBUILD
downloadaur-818b1533c4781cc269ffe84593f3745ed05815e7.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bb4d84a1cd53
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Contributor: Your Name <youremail@domain.com>
+pkgname=perl-lazy-utils
+pkgver=1.22
+pkgrel=1
+pkgdesc="ORKUN's collection of utility functions Lazy::Util"
+_dist=Lazy-Utils
+arch=('any')
+url="https://metacpan.org/release/$_dist"
+license=('GPL3')
+depends=(perl perl-json)
+options=('!emptydirs' purge)
+source=("https://search.cpan.org/CPAN/authors/id/O/OR/ORKUN/$_dist-$pkgver.tar.gz")
+sha256sums=('73aec71fc292a9f606d700192820935bb11177725516e93904652b3a4b78ee91')
+
+build() {
+ cd "$srcdir/$_dist-$pkgver"
+
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
+ /usr/bin/perl Makefile.PL
+ make
+}
+
+check() {
+ cd "$srcdir/$_dist-$pkgver"
+
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1
+ make test
+}
+
+package() {
+ cd "$srcdir/$_dist-$pkgver"
+
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
+}
+