summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGergan Penkov2015-08-02 11:43:17 +0200
committerGergan Penkov2015-08-02 11:43:17 +0200
commit045fcc5d72a1c342a3ea9f8d8ca35a1cc3508eb6 (patch)
tree92051bae54b8aba9adbbc69aa3b53f8ccbf6103c /PKGBUILD
downloadaur-perl-lwp-protocol-http10.tar.gz
import from aur
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cf5607f49be0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Maxwell Pray a.k.a. Synthead <synthead@gmail.com>
+
+pkgname='perl-lwp-protocol-http10'
+_cpanname='LWP-Protocol-http10'
+pkgver='6.03'
+pkgrel='1'
+pkgdesc='Support for using HTTP/1.0 protocol with LWP.'
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl>=5.5.0')
+url="http://search.cpan.org/~gaas/$_cpanname-$pkgver/"
+source=("http://search.cpan.org/CPAN/authors/id/G/GA/GAAS/$_cpanname-$pkgver.tar.gz")
+md5sums=('c3d2f6efc2ce06066cf95a24fed6fff1')
+
+
+# Function to change to the working directory and set
+# environment variables to override undesired options.
+prepareEnvironment() {
+ cd "$srcdir/$_cpanname-$pkgver"
+ export \
+ PERL_MM_USE_DEFAULT=1 \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+}
+
+build() {
+ prepareEnvironment
+ /usr/bin/perl Makefile.PL
+ make
+}
+
+check() {
+ prepareEnvironment
+ make test
+}
+
+package() {
+ prepareEnvironment
+ make install
+
+ # Remove "perllocal.pod" and ".packlist".
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}