summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorint2017-10-05 14:06:53 +0200
committerint2017-10-05 14:06:53 +0200
commit661e36f78616d9dad11936611dc6c2e42960ec30 (patch)
treee3fd9fd79cb5e29422c5d182a8041fce665e89fa /PKGBUILD
downloadaur-661e36f78616d9dad11936611dc6c2e42960ec30.tar.gz
Perl/CPAN Module MARC::Record.
This is one of the perl-dependencies of Koha: https://koha-community.org/ Start "./koha_perl_deps.pl -r -a" after downloading and unpacking the koha-tarball for a list of all required packages. This is with the cpan2aur-bugfix, see https://rt.cpan.org/Public/Bug/Display.html?id=123153 for details.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..84953bee2fa5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer : int <int [ate] arcor [dot] de>
+# Generator : CPANPLUS::Dist::Arch 1.32
+
+pkgname='perl-marc-record'
+pkgver='2.0.6'
+pkgrel='1'
+pkgdesc="Perl/CPAN Module MARC::Record: Perl extension for handling MARC records"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl')
+makedepends=()
+url='https://metacpan.org/release/MARC-Record'
+source=('http://search.cpan.org/CPAN/authors/id/G/GM/GMCHARLT/MARC-Record-2.0.6.tar.gz')
+md5sums=('cf2ddaa83059c5f135b0ee9463520b88')
+sha512sums=('7a3436adbe6e5365ec2810ebf3c64d22ae707cedbfccf02f562d253c7727c33f9ea36a47a7acdba12bbf32693b4c70913a0c551b5605388fb39fa379d099af8d')
+_distdir="MARC-Record-2.0.6"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+ find "$pkgdir" "(" -name .packlist -o -name perllocal.pod -o -name Tutorial.pod ")" -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: