summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSebastian 'Swift Geek' Grzywna2017-02-28 02:42:28 +0100
committerSebastian 'Swift Geek' Grzywna2017-02-28 02:42:28 +0100
commit0b6ba360ba52fa03fa7eafb6aef1740fd9f37a0a (patch)
treeded42584f8066b375b0c993f5884cb9969b3c660 /PKGBUILD
parent6c34f48e6dbcf394cad62e8674a602e4ed0de6a1 (diff)
downloadaur-0b6ba360ba52fa03fa7eafb6aef1740fd9f37a0a.tar.gz
Fix use with makepkg -e and -o options
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 6 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1032cc682b70..fb0d72881340 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,30 +16,27 @@ options=(!emptydirs)
install=
source=("http://search.cpan.org/CPAN/authors/id/K/KR/KRYDE/Math-PlanePath-${pkgver}.tar.gz")
md5sums=('88d173b046906876c53950af14a56b9c')
+_src_dir='$srcdir/Math-PlanePath-$pkgver'
-prepare() {
- export _src_dir="$srcdir/Math-PlanePath-$pkgver"
+build() {
# Setting these env variables overwrites any command-line-options we don't want...
export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps \
PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
MODULEBUILDRC=/dev/null
-}
-
-build() {
- cd "$_src_dir"
+ eval cd "$_src_dir"
/usr/bin/perl Makefile.PL
make
}
check () {
- cd "$_src_dir"
+ eval cd "$_src_dir"
make test
}
package () {
- cd "$_src_dir"
- echo "$_src_dir"
+ eval cd "$_src_dir"
+ pwd
make install
# remove perllocal.pod and .packlist