summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorint2017-10-17 22:55:56 +0200
committerint2017-10-17 22:55:56 +0200
commitc01b8567ec225834536c0409d1308b6de4fae3b6 (patch)
treeaa52e62431ed293f016ef26f2a74474b0d5fdadc /PKGBUILD
downloadaur-c01b8567ec225834536c0409d1308b6de4fae3b6.tar.gz
Perl/CPAN Module Module::Bundled::Files
This is one of the (optional) perl-dependencies of Koha: https://koha-community.org/ Start "./koha_perl_deps.pl -a" after downloading and unpacking the koha-tarball for a list of all packages (required and optional). This is with the cpan2aur-bugfix, see https://rt.cpan.org/Public/Bug/Display.html?id=123153 for details.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9f4f5c170e04
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer : int <int [ate] arcor [dot] de>
+# Generator : CPANPLUS::Dist::Arch 1.32
+
+pkgname='perl-module-bundled-files'
+pkgver='0.03'
+pkgrel='1'
+pkgdesc="Perl/CPAN Module Module::Bundled::Files: Access files bundled with Module"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl-class-isa' 'perl-module-build>=0.26')
+makedepends=()
+url='https://metacpan.org/release/Module-Bundled-Files'
+source=("http://search.cpan.org/CPAN/authors/id/P/PC/PCAMPBELL/Module-Bundled-Files-$pkgver.tar.gz")
+md5sums=('bcefaf9448046a0d379775216027bfd7')
+sha512sums=('d61f6de2522fe1e877607eb945cb4769524e0444dc58e68fdb794de00c8d5eed2206b600c651d595a49912ae7da2643a68d8e14ee5e8c4599cdf7e8d249de048')
+_distdir="Module-Bundled-Files-$pkgver"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" "(" -name .packlist -o -name perllocal.pod ")" -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: