summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormutantmonkey2013-12-13 18:20:26 -0800
committermutantmonkey2013-12-13 18:20:26 -0800
commit417c8f2651a04dc8e0c0ba16d0b54df20b24ca1e (patch)
treeb6812295e989cd30587d780b1b24498f723ea95c /PKGBUILD
downloadaur-417c8f2651a04dc8e0c0ba16d0b54df20b24ca1e.tar.gz
add perl-mousex-{getopt,types-path-class,types}
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..142741690074
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: mutantmonkey <aur@mutantmonkey.in>
+_author=GFUJI
+_perlmod=MouseX-Getopt
+pkgname=perl-mousex-getopt
+pkgver=0.34
+pkgrel=1
+pkgdesc="Organize your Mouse types in libraries"
+arch=('any')
+url="http://search.cpan.org/~$_author/$_perlmod-$pkgver/"
+license=('GPL' 'PerlArtistic')
+depends=('perl>=5.10.0')
+options=(!emptydirs)
+source=(http://search.cpan.org/CPAN/authors/id/G/GF/$_author/$_perlmod-$pkgver.tar.gz)
+sha256sums=('a1acee93e1fcf438fbf847aeffd98fd0197009c8ffda13b412c77106c9cbe4ea')
+
+build() {
+ cd "$srcdir/$_perlmod-$pkgver"
+
+ # Install module in vendor directories.
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+package() {
+ cd "$srcdir/$_perlmod-$pkgver"
+ make install DESTDIR="$pkgdir/"
+}
+
+# vim:set ts=2 sw=2 et: