aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Grimes2013-11-19 11:56:20 -0500
committerMark Grimes2013-11-19 11:56:20 -0500
commit568e0b30f72a1d6ed4270d9d8cda4228e4ebfbe7 (patch)
treef4925fcfa5b68861b69eb8ac7617505aed739778 /PKGBUILD
downloadaur-568e0b30f72a1d6ed4270d9d8cda4228e4ebfbe7.tar.gz
Status when adopted
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f554bd1bbf23
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: sh0 <mee@sh0.org>
+pkgname=perl-nagios-plugin
+pkgver=0.35
+pkgrel=1
+pkgdesc="A family of perl modules to streamline writing Nagios plugins"
+arch=('any')
+url="http://search.cpan.org/dist/Nagios-Plugin"
+license=('unknown')
+depends=('perl>=5.10.0' 'perl-params-validate' 'perl-class-accessor' 'perl-config-tiny' 'perl-math-calc-units')
+options=(!emptydirs)
+source=(http://search.cpan.org/CPAN/authors/id/T/TO/TONVOON/Nagios-Plugin-$pkgver.tar.gz)
+md5sums=('96b3510798e28f3ebed8c23f4225e80e')
+
+build() {
+ cd "$srcdir/Nagios-Plugin-$pkgver"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+package() {
+ cd "$srcdir/Nagios-Plugin-$pkgver"
+ make install DESTDIR="$pkgdir/"
+ find $pkgdir -name '.packlist' -delete
+ find $pkgdir -name '*.pod' -delete
+}
+
+# vim:set ts=2 sw=2 et: