summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorint2024-05-19 20:57:42 +0200
committerint2024-05-19 20:57:42 +0200
commitb1840c0aef3b810958179e60c6331793a4672e51 (patch)
treec909eb210e28076b2ecb1ed9c155e98e55c65bcc /PKGBUILD
parenta700e751be1cd8b83cacbaa34212c8da7cd98462 (diff)
downloadaur-b1840c0aef3b810958179e60c6331793a4672e51.tar.gz
Don't run failing tests.
Some tests rely on host z3950.indexdata.com/gils, which is down. These tests fail because of it. Don't run them. Note: The debian-package of this perl-module also skips these tests.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4eee685a4df7..5eacc39ccf12 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname='perl-net-z3950-zoom'
pkgver='1.30'
-pkgrel='2'
+pkgrel='3'
pkgdesc="Perl/CPAN Module Net::Z3950::ZOOM: Perl extension for invoking the ZOOM-C API."
arch=('i686' 'x86_64')
license=('PerlArtistic' 'GPL')
@@ -11,10 +11,10 @@ options=('!emptydirs')
depends=('glibc>=2.25' 'libgcrypt>=1.7.6' 'libgpg-error>=1.27' 'libxml2>=2.9.4+16+g07418011' 'libxslt>=1.1.29+42+gac341cbd' 'perl-marc-record>=1.38' 'xz>=5.2.3' 'yaz>=5.21.1' 'zlib>=1:1.2.11')
makedepends=()
url='https://metacpan.org/release/Net-Z3950-ZOOM'
-source=('http://search.cpan.org/CPAN/authors/id/M/MI/MIRK/Net-Z3950-ZOOM-1.30.tar.gz')
+source=("http://search.cpan.org/CPAN/authors/id/M/MI/MIRK/Net-Z3950-ZOOM-${pkgver}.tar.gz")
md5sums=('eb1e6a880b9cb09ac44df97a914dba59')
sha512sums=('6511786d9d25070eb370313428b25e32120b4d591e1dbe585933b57e210423ea5b599bfdd995e65682a0963854b0ad7143c80d90b81f1e511c3ed23e44b6a7cc')
-_distdir="Net-Z3950-ZOOM-1.30"
+_distdir="Net-Z3950-ZOOM-${pkgver}"
build() {
( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
@@ -31,8 +31,9 @@ build() {
check() {
cd "$srcdir/$_distdir"
+ echo "Only run the tests that don't rely on host z3950.indexdata.com/gils, which is down."
( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
- make test
+ make test TEST_FILES='t/*-options.t t/*-option-callback.t t/*-logging.t'
)
}