summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCpanBot2023-11-07 12:52:30 +0000
committerCpanBot2023-11-07 12:52:30 +0000
commit0fbb5e7578fd54ee043438e5d5d6ed2d1d0fea06 (patch)
treec9525e5e1176e48defd3cc2c38e9eae8cb20ebf2 /PKGBUILD
parent67228609b1831ac3de7c31a8a3d6e2284d7e58b3 (diff)
downloadaur-perl-netpacket.tar.gz
Converted 'NetPacket' with cpan2aur2git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD72
1 files changed, 43 insertions, 29 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e52325b7a8c0..0cac66dcb0fd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,49 @@
-# Contributor: Eduardo Reveles <me at osiux dot ws>
+# Contributor: CpanBot <cpanbot at sch bme hu>
+# Generator : CPANPLUS::Dist::Arch 1.32
-pkgname=perl-netpacket
-pkgver=1.6.0
-pkgrel=1
+pkgname='perl-netpacket'
+pkgver='1.7.2'
+pkgrel='1'
pkgdesc="assemble/disassemble network packets at the protocol level"
-_dist=NetPacket
arch=('any')
-url="https://metacpan.org/release/$_dist"
-license=('GPL' 'PerlArtistic')
-depends=(perl)
-options=('!emptydirs' purge)
-source=("http://search.cpan.org/CPAN/authors/id/Y/YA/YANICK/$_dist-$pkgver.tar.gz")
-md5sums=('17ba0407dada096f046f513387e88818')
+license=('Artistic2.0')
+options=('!emptydirs')
+depends=('perl>=5.10.0')
+makedepends=()
+url='https://metacpan.org/release/NetPacket'
+source=('http://search.cpan.org/CPAN/authors/id/Y/YA/YANICK/NetPacket-1.7.2.tar.gz')
+md5sums=('6821d0c7a553308cdcd868737055bb3d')
+sha512sums=('94fb9b99f8d5443cce76c943ab562b44ee07448b0fbdd86bea35e0dc1aeabbce3871d7115f68c8ca013ad71390c51f2d5233a8f4ad71d796920c3f286cecf4c5')
+_distdir="NetPacket-1.7.2"
-build() (
- cd "$srcdir/$_dist-$pkgver"
- unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
- export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
- /usr/bin/perl Makefile.PL
- make
-)
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
-check() (
- cd "$srcdir/$_dist-$pkgver"
- unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
- export PERL_MM_USE_DEFAULT=1
- make test
-)
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
-package() (
- cd "$srcdir/$_dist-$pkgver"
- unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
- make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
-) \ No newline at end of file
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: