summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohn D Jones III2015-06-16 15:39:08 -0600
committerJohn D Jones III2015-06-16 15:39:08 -0600
commit17afae3a7194c08412b2b96576f40019b5054381 (patch)
treea29aa57fced0ad337f9dcda463e0594b1fce869d /PKGBUILD
downloadaur-17afae3a7194c08412b2b96576f40019b5054381.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..33cf4b2e25a3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Contributor: John D Jones III <j[nospace]n[nospace]b[nospace]e[nospace]k[nospace]1972 -_AT_- the domain name google offers a mail service at ending in dot com>
+# Generator : CPANPLUS::Dist::Arch 1.25
+
+pkgname='perl-number-format'
+pkgver='1.73'
+pkgrel='1'
+pkgdesc="Perl extension for formatting numbers"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl')
+makedepends=()
+url='http://search.cpan.org/dist/Number-Format'
+source=('http://search.cpan.org/CPAN/authors/id/W/WR/WRW/Number-Format-1.73.tar.gz')
+md5sums=('3a4188de6e84b04361def285b93dc240')
+sha512sums=('52af1a595d9a62c9aabd57407c1807e71c7f2bfc591a835f73428848162fc0ab5aee7e78a8269304d44fceeb2654b8db40686eed8c6ff83e821b905905c75047')
+_distdir="Number-Format-1.73"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: