summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAnton Leontiev2015-08-12 10:51:38 +0300
committerAnton Leontiev2015-08-12 10:51:38 +0300
commitea4a7b2119c113f827d17cf52ea855ca020dc4d1 (patch)
treee340d4d2b9b49716389eaa02a4d9d69e4ff0dcc7 /PKGBUILD
parent4ba8c0eccc17e5c30bcbe3e804b64403486f764f (diff)
downloadaur-ea4a7b2119c113f827d17cf52ea855ca020dc4d1.tar.gz
Updated to v0.0409
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 17 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 60b1859b93ec..4c1e62dc89d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,41 @@
# CPAN Name : Ouch
# Contributor: Anton Leontiev <bunder /at/ t-25.ru>
-# Generator : CPANPLUS::Dist::Arch 1.28
+# Generator : CPANPLUS::Dist::Arch 1.30
pkgname=perl-ouch
-pkgver=0.0408
+pkgver=0.0409
pkgrel=1
pkgdesc="Perl module for exceptions that don't hurt"
arch=('any')
-url='http://search.cpan.org/dist/Ouch'
+url='https://metacpan.org/release/Ouch'
license=('PerlArtistic' 'GPL')
depends=('perl>=5.10.1')
checkdepends=('perl-test-trap')
-source=(http://search.cpan.org/CPAN/authors/id/R/RI/RIZEN/Ouch-0.0408.tar.gz)
+source=(http://search.cpan.org/CPAN/authors/id/R/RI/RIZEN/Ouch-0.0409.tar.gz)
options=(!emptydirs)
-md5sums=('f3cd70271ba8f7598569bc04097b7881')
+md5sums=('7bfb9b0724761d845bba6ba3945f53f2')
+
+sanitize() {
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1
+}
build() {
- cd Ouch-0.0408
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ cd Ouch-0.0409
+ sanitize
+ perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd Ouch-0.0408
+ cd Ouch-0.0409
+ sanitize
make test
}
package() {
- cd Ouch-0.0408
+ cd Ouch-0.0409
+ sanitize
make install DESTDIR="$pkgdir"
find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}