summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLukáš Jirkovský2015-07-01 22:19:04 +0200
committerLukáš Jirkovský2015-07-01 22:19:04 +0200
commitce133ff0673a2cdc9892a290afa268bcd1990d60 (patch)
treed4aac037521cd2c551ae52a7bc97d3e1e49308aa /PKGBUILD
downloadaur-perl-panotools-script.tar.gz
initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f06e835250c9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Lukas Jirkovsky <l.jirkovsky@gmail.com>
+pkgname=perl-panotools-script
+pkgver=0.28
+pkgrel=1
+pkgdesc="Perl/CPAN Module Panotools::Script : Panorama Tools scripting"
+arch=('any')
+url="http://search.cpan.org/dist/Panotools-Script/"
+license=("GPL2")
+depends=('perl')
+checkdepends=('hugin')
+optdepends=('zenity: GUI' 'enblend-enfuse: enblend-* enfuse-* scripts' \
+ 'imagemagick: entile' 'perl-image-size: erect2* and few other scripts' \
+ 'hugin: tools for generating panorama projects')
+source=(http://search.cpan.org/CPAN/authors/id/B/BP/BPOSTLE/Panotools-Script-$pkgver.tar.gz)
+md5sums=('c4b15c5672a2d757ca46fd87cc536a91')
+
+build() {
+ cd "$srcdir"/Panotools-Script-$pkgver
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$srcdir"/Panotools-Script-$pkgver
+ make -k test
+}
+
+package() {
+ cd "$srcdir"/Panotools-Script-$pkgver
+ make install DESTDIR="$pkgdir"
+}