summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPiotr Rogoża2018-09-05 22:01:58 +0200
committerPiotr Rogoża2018-09-05 22:01:58 +0200
commitcd83e8fe2359ab1063806683ce8efeb66c244027 (patch)
tree8b8dec0a3947ef7de3458cb9fc48afa8768a2789 /PKGBUILD
parentb813c6c54bb7834075316eb32df0316ff9b91b1f (diff)
downloadaur-cd83e8fe2359ab1063806683ce8efeb66c244027.tar.gz
Upgraded to 1.00005
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 16 insertions, 33 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f8f80e6bd36d..3b6e3d6fcb00 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,7 @@
# Maintainer: Piotr Rogoza <piotr dot r dot public at gmail dot com>
-# Contributor: Piotr Rogoza <piotr dot r dot public at gmail dot com>
pkgname=perl-pod-coverage-trustpod
-pkgver=0.100003
+pkgver=0.100005
pkgrel=1
_author='R/RJ/RJBS'
_perlmod='Pod-Coverage-TrustPod'
@@ -17,49 +16,33 @@ perl-pod-coverage
provides=()
options=(!emptydirs)
source=("http://search.cpan.org/CPAN/authors/id/$_author/$_perlmod-$pkgver.tar.gz")
-sha256sums=('3f0c42c4656cf22dab0e7c92c9006eb90a4a3068d6950938c4773c5854619ea6')
+sha256sums=('6c68835c24cdcafbb1567e680ab12bb17616382baf8bc44ce457e41a1d357321')
+unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps MODULEBUILDRC=/dev/null
build(){
cd "$srcdir"/$_perlmod-$pkgver
-
- # Setting these env variables overwrites any command-line-options we don't want...
- export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps \
- PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
- PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
- MODULEBUILDRC=/dev/null
-
- # If using Makefile.PL
- if [ -r Makefile.PL ]; then
- /usr/bin/perl Makefile.PL
+ if [ -f Makefile.PL ]; then
+ perl Makefile.PL
make
- # If using Build.PL
- elif [ -r Build.PL ]; then
- /usr/bin/perl Build.PL
- perl Build
+ else
+ perl Build.PL
+ ./Build
fi
}
check(){
cd "$srcdir"/$_perlmod-$pkgver
-
- # If using Makefile.PL
- if [ -r Makefile.PL ]; then
+ if [ -f Makefile.PL ]; then
make test
- # If using Build.PL
- elif [ -r Build.PL ]; then
- perl Build test
+ else
+ ./Build test
fi
}
package(){
cd "$srcdir"/$_perlmod-$pkgver
-
- # If using Makefile.PL
- if [ -r Makefile.PL ]; then
- make install
- # If using Build.PL
- elif [ -r Build.PL ]; then
- perl Build install
+ if [ -f Makefile.PL ]; then
+ make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
+ else
+ ./Build install --installdirs=vendor --destdir="$pkgdir"
fi
-
- # remove perllocal.pod and .packlist
- find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}