summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAnton Leontiev2021-01-07 12:03:31 +0300
committerAnton Leontiev2021-01-07 12:12:00 +0300
commit45c28aeabc693a8ed46a0caf812f1195d39fba27 (patch)
tree5fef3d876ef100680b785d07dc79ba1482b4a8d5 /PKGBUILD
parent8183df6245ed00e37a70f5b5530d0d837690c784 (diff)
downloadaur-perl-posix-strftime-compiler.tar.gz
perl-posix-strftime-compiler: Update to v0.44
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 13 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6cd6fad21805..da36632ed9f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,17 @@
# Generator : CPANPLUS::Dist::Arch 1.32
pkgname=perl-posix-strftime-compiler
-pkgver=0.42
-pkgrel=2
+pkgver=0.44
+pkgrel=1
pkgdesc='Perl module providing GNU C library compatible strftime for loggers and servers'
arch=('any')
url='https://metacpan.org/release/POSIX-strftime-Compiler'
license=('PerlArtistic' 'GPL')
-depends=('perl>=5.8.1')
-makedepends=('perl-module-build>=0.38')
-source=(http://search.cpan.org/CPAN/authors/id/K/KA/KAZEBURO/POSIX-strftime-Compiler-0.42.tar.gz)
+depends=('perl')
+makedepends=('perl-module-build-tiny>=0.035')
+source=(http://search.cpan.org/CPAN/authors/id/K/KA/KAZEBURO/POSIX-strftime-Compiler-0.44.tar.gz)
options=(!emptydirs)
-md5sums=('c0a5f76b1b0ce9cdb90d627b017e6cf5')
+md5sums=('3a5ae7d56a5917410c1b661e01ed1a68')
sanitize() {
unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
@@ -21,21 +21,21 @@ sanitize() {
}
build() {
- cd POSIX-strftime-Compiler-0.42
+ cd POSIX-strftime-Compiler-0.44
sanitize
- perl Build.PL --installdirs vendor --destdir "$pkgdir"
- perl Build
+ /usr/bin/perl Build.PL --installdirs vendor --destdir "$pkgdir"
+ /usr/bin/perl Build
}
check() {
- cd POSIX-strftime-Compiler-0.42
+ cd POSIX-strftime-Compiler-0.44
sanitize
- perl Build test
+ /usr/bin/perl Build test
}
package() {
- cd POSIX-strftime-Compiler-0.42
+ cd POSIX-strftime-Compiler-0.44
sanitize
- perl Build install
+ /usr/bin/perl Build install
find "$pkgdir" \( -name .packlist -o -name perllocal.pod \) -delete
}