summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoroli2015-06-12 22:02:31 +0200
committeroli2015-06-12 22:02:31 +0200
commit497042fa4843770f8ec44b1f25b01cf713dcb6c4 (patch)
tree8e3299cad7f4350c3c9ade62d2aa0f3983c3bee0 /PKGBUILD
downloadaur-497042fa4843770f8ec44b1f25b01cf713dcb6c4.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8c10218e2bd1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# This PKGBUILD was inspired by cpan4pacman
+# Maintainer: Jozef Riha <jose1711 at gmail dot com>
+
+pkgname=perl-proc-parallelloop
+_cpanname=Proc-ParallelLoop
+pkgver=0.5
+pkgrel=2
+pkgdesc="Parallel looping constructs for Perl programs"
+arch=('any')
+url="http://search.cpan.org/~bdarrah/${_cpanname}"
+license=('GPL' 'PerlArtistic')
+depends=('perl')
+options=('!emptydirs')
+source=(http://www.cpan.org/authors/id/B/BD/BDARRAH/${_cpanname}-${pkgver}.tgz)
+md5sums=('cc60f8a69454d64cc5a0f0b57171b13c')
+
+build() {
+ cd $srcdir/${_cpanname}-${pkgver}
+ sed -i '/^auto_install/d' Makefile.PL
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+package() {
+ cd $srcdir/${_cpanname}-${pkgver}
+ make install DESTDIR=$pkgdir
+ find $pkgdir -name '.packlist' -delete
+ find $pkgdir -name '*.pod' -delete
+}