summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Cafe2018-08-06 16:05:28 -0300
committerDaniel Cafe2018-08-06 16:05:28 -0300
commitda7d64e34d1dcd7ce267d644f24424c355995058 (patch)
treead8d2bceaaf7a30d8c7dac43ee9e220af9c264d9 /PKGBUILD
parentda2d15496b5129810d95596fe9c07e0013e762d8 (diff)
downloadaur-perl-quota.tar.gz
Adjusted for tirpc
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5d3a53dfabf7..17bb775612a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Contributor: Daniel Café <dccafe@gmail.com>
pkgname=perl-quota
pkgver=1.7.2
-pkgrel=1
+pkgrel=2
pkgdesc='Quota - Perl interface to file system quotas'
_dist=Quota
arch=('any')
url="https://metacpan.org/release/$_dist"
license=('GPL' 'PerlArtistic')
-depends=(perl)
+depends=('perl' 'libtirpc' 'rpcsvc-proto')
options=('!emptydirs' purge)
source=("http://search.cpan.org/CPAN/authors/id/T/TO/TOMZO/$_dist-$pkgver.tar.gz")
md5sums=(d4ed0acc56ece4e5080a7a6d827e9c66)
@@ -17,6 +17,8 @@ build() {
unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
/usr/bin/perl Makefile.PL
+ sed -i 's/-shared/-ltirpc -shared/g' Makefile
+ sed -i 's/usr\/local\/include/usr\/include\/tirpc/g' Makefile
make
}