summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorint2017-10-07 23:41:42 +0200
committerint2017-10-07 23:41:42 +0200
commit8090b123b1c8a3f8fea40522873fa6d498d9685b (patch)
tree87ad8571c0a32ebfb35c905ec2ab9d9f02516f80 /PKGBUILD
downloadaur-8090b123b1c8a3f8fea40522873fa6d498d9685b.tar.gz
Perl/CPAN Module Schedule::At.
This is one of the perl-dependencies of Koha: https://koha-community.org/ Start "./koha_perl_deps.pl -r -a" after downloading and unpacking the koha-tarball for a list of all required packages. This is with the cpan2aur-bugfix, see https://rt.cpan.org/Public/Bug/Display.html?id=123153 for details.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2ebe47134e07
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer : int <int [ate] arcor [dot] de>
+# Generator : CPANPLUS::Dist::Arch 1.32
+
+pkgname='perl-schedule-at'
+pkgver='1.15'
+pkgrel='1'
+pkgdesc="Perl/CPAN Module Schedule::At: OS independent interface to the Unix 'at' command"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl')
+makedepends=()
+url='https://metacpan.org/release/Schedule-At'
+source=('http://search.cpan.org/CPAN/authors/id/J/JO/JOSERODR/Schedule-At-1.15.tar.gz')
+md5sums=('218b42b6ad2a2c2ddb0d54aeb0921496')
+sha512sums=('15df903f990d4b72fd921fb838b00d61261c711fd963a03a6dad6a55ce86a3da268e5efa5446d477ba4bfe1e25d74ab703f4121411b79ac1001b55d136e4fd74')
+_distdir="Schedule-At-1.15"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+ find "$pkgdir" "(" -name .packlist -o -name perllocal.pod ")" -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: