summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPiotr Rogoża2017-06-20 20:18:56 +0200
committerPiotr Rogoża2017-06-20 20:18:56 +0200
commit198a703f7c2f1e52580c910ebde118ac049c2fc8 (patch)
tree1e6d5f9ab2458c40064a55d2fb918115d2fdeab7 /PKGBUILD
downloadaur-198a703f7c2f1e52580c910ebde118ac049c2fc8.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3d9c2ca1e270
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: dracorp aka Piotr Rogoza <piotr.r.public at gmail.com>
+
+pkgname=perl-shell-config-generate
+pkgver=0.26
+pkgrel=1
+_author="P/PL/PLICEASE"
+_perlmod="Shell-Config-Generate"
+pkgdesc="Shell::Config::Generate - Portably generate config for any shell"
+arch=('any')
+url="http://search.cpan.org/dist/shell-config-generate/"
+license=('GPL' 'PerlArtistic')
+depends=(perl)
+options=(!emptydirs)
+source=("http://search.cpan.org/CPAN/authors/id/$_author/$_perlmod-$pkgver.tar.gz")
+sha256sums=('4378dceec22c15a3ec51768b1e6b16719eaab65f5852969bfc1d897f77df3812')
+unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps MODULEBUILDRC=/dev/null
+build(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ if [ -f Makefile.PL ]; then
+ perl Makefile.PL
+ make
+ else
+ perl Build.PL
+ ./Build
+ fi
+}
+check(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ if [ -f Makefile.PL ]; then
+ make test
+ else
+ ./Build test
+ fi
+}
+package(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ if [ -f Makefile.PL ]; then
+ make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
+ else
+ ./Build install --installdirs=vendor --destdir="$pkgdir"
+ fi
+}
+