summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAnton Leontiev2014-06-09 08:27:58 +0400
committerAnton Leontiev2015-02-15 07:48:22 +0300
commitee46c789bfd9ec4b1f9ee3077d8a9341be363012 (patch)
treeb4b7acc665dc8a1d06d4f2ea5d5c123e56aac188 /PKGBUILD
downloadaur-ee46c789bfd9ec4b1f9ee3077d8a9341be363012.tar.gz
Initial v0.15
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7074bb0a9404
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# CPAN Name : String::Print
+# Contributor: Anton Leontiev <bunder /at/ t-25.ru>
+# Generator : CPANPLUS::Dist::Arch 1.28
+
+pkgname=perl-string-print
+pkgver=0.15
+pkgrel=1
+pkgdesc='Perl package providing printf() alternative'
+arch=('any')
+url='http://search.cpan.org/dist/String-Print'
+license=('PerlArtistic' 'GPL')
+depends=('perl>=5.10.1' 'perl-unicode-linebreak')
+source=(http://search.cpan.org/CPAN/authors/id/M/MA/MARKOV/String-Print-0.15.tar.gz)
+options=(!emptydirs)
+md5sums=('469f5a0517a6820abe52f7e23dc9e58b')
+
+build() {
+ cd String-Print-0.15
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd String-Print-0.15
+ make test
+}
+
+package() {
+ cd String-Print-0.15
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}