summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKrzysztof (3ED) AS2015-07-02 10:03:49 +0200
committerKrzysztof (3ED) AS2015-07-02 10:03:49 +0200
commit0914d0410598b2b43fc2c4911703a17cdfe5a8c7 (patch)
tree55b64b3c77692b5e4c6f6dbd9134ddc8a1ad2fdb /PKGBUILD
downloadaur-0914d0410598b2b43fc2c4911703a17cdfe5a8c7.tar.gz
moving files, making space for additional scripts, aur4 and other stuff
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eb41a7c67751
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Mantainer: 3ED <krzysztof1987 at gmail dot com>
+#
+pkgname=perl-string-urandom
+_lastauthor=M/MB/MBROOKS
+_pkgname=String-Urandom
+pkgver=0.16
+pkgrel=3
+pkgdesc="An alternative to using /dev/random"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl-params-validate')
+makedepends=('perl-extutils-makemaker')
+url="http://search.cpan.org/dist/${_pkgname}/"
+source=(http://search.cpan.org/CPAN/authors/id/${_lastauthor}/${_pkgname}-${pkgver}.tar.gz)
+sha256sums=('c1dc53e8483a77f3b5fa0c41ad843699420d46411ffb0b30bc4c70dd863b5139')
+
+build() {
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL="--skipdeps" \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ perl Makefile.PL
+ make
+}
+check() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ make test
+}
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ make install
+}