summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStefan Göbel2023-11-14 19:44:07 +0100
committerStefan Göbel2023-11-14 19:44:07 +0100
commit45fcff9c0c9df87dbd551961d2a750b7d17a38a7 (patch)
tree44cdf131b3d89b76de8897af59a2884b33cbe22e /PKGBUILD
parente57d64d4cd81a599cf5be601469c0a5f91dba696 (diff)
downloadaur-45fcff9c0c9df87dbd551961d2a750b7d17a38a7.tar.gz
upgpkg: perl-test-classapi 1.07-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD68
1 files changed, 34 insertions, 34 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 033f8e6bbab3..69696a1fb0df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,50 +1,50 @@
+# Maintainer: Stefan Göbel <aur —at— subtype —dot— de>
# Contributor: John D Jones III <j[nospace]n[nospace]b[nospace]e[nospace]k[nospace]1972 -_AT_- the domain name google offers a mail service at ending in dot com>
-# Generator : CPANPLUS::Dist::Arch 1.25
pkgname='perl-test-classapi'
-pkgver='1.06'
+_module='Test-ClassAPI'
+_author='E/ET/ETHER'
+pkgver='1.07'
pkgrel='1'
-pkgdesc="Provides basic first-pass API testing for large class trees"
+pkgdesc='Provides basic first-pass API testing for large class trees'
arch=('any')
license=('PerlArtistic' 'GPL')
options=('!emptydirs')
-depends=('perl-class-inspector>=1.12' 'perl-config-tiny>=2.00' 'perl-params-util>=1.00')
-makedepends=()
-url='http://search.cpan.org/dist/Test-ClassAPI'
-source=('http://search.cpan.org/CPAN/authors/id/A/AD/ADAMK/Test-ClassAPI-1.06.tar.gz')
-md5sums=('ee31a9e1ecedcf720a9e89461a83442e')
-sha512sums=('f84385b8b83db52243513c86422775e448eaa3a0353a48e38c5fc4f6b5487ae59655c4a12745297f0c4416c1388b48e83c39065614a629f1343bf8693bddaa77')
-_distdir="Test-ClassAPI-1.06"
+depends=(
+ 'perl-class-inspector>=1.12'
+ 'perl-config-tiny>=2.00'
+ 'perl-params-util>=1.00'
+)
+url="https://metacpan.org/release/$_module"
+source=("https://cpan.metacpan.org/authors/id/$_author/$_module-$pkgver.tar.gz")
+sha256sums=('30e9dbfc5e0cc2ee14eae8f3465a908a710daecbd0a3ebdb2888fc4504fa18aa')
build() {
- ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
- PERL_AUTOINSTALL=--skipdeps \
- PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
- PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
- MODULEBUILDRC=/dev/null
-
- cd "$srcdir/$_distdir"
- /usr/bin/perl Makefile.PL
- make
- )
+ (
+ cd "$_module-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT='1' PERL_AUTOINSTALL='--skipdeps'
+ perl Makefile.PL INSTALLDIRS='vendor'
+ make
+ )
}
check() {
- cd "$srcdir/$_distdir"
- ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
- make test
- )
+ (
+ cd "$_module-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT='1'
+ make test
+ )
}
package() {
- cd "$srcdir/$_distdir"
- make install
-
- find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+ (
+ cd "$_module-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ make install INSTALLDIRS='vendor' DESTDIR="$pkgdir"
+ find "$pkgdir" -name .packlist -delete
+ find "$pkgdir" -name perllocal.pod -delete
+ find "$pkgdir" -type d -empty -delete
+ )
}
-
-# Local Variables:
-# mode: shell-script
-# sh-basic-offset: 2
-# End:
-# vim:set ts=2 sw=2 et: