summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohn D Jones III2015-06-16 16:06:16 -0600
committerJohn D Jones III2015-06-16 16:06:16 -0600
commit722b56ba86d56fac9752e9ba14cf15e19ecd97f9 (patch)
treee0acc68406b429379a92fdb0f1e216fb5bcc950a /PKGBUILD
downloadaur-perl-text-caml.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..943900633a90
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Contributor: John D Jones III <j[nospace]n[nospace]b[nospace]e[nospace]k[nospace]1972 -_AT_- the domain name google offers a mail service at ending in dot com>
+# Generator : CPANPLUS::Dist::Arch 1.25
+
+pkgname='perl-text-caml'
+pkgver='0.10'
+pkgrel='1'
+pkgdesc="Mustache template engine"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl')
+makedepends=()
+url='http://search.cpan.org/dist/Text-Caml'
+source=('http://search.cpan.org/CPAN/authors/id/V/VT/VTI/Text-Caml-0.10.tar.gz')
+md5sums=('b129a4f5781e87a64f1a940c017f74e1')
+sha512sums=('a0252b7a4d8c2ce1bfb9f43efdec5be4f9561034821f43ff0b03bc8d23f6c34d349afed057bfb5dfa80adfc62e2640531ac600f6bb0199302136971a11bbbd12')
+_distdir="Text-Caml-0.10"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: