summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarcell Meszaros2024-02-18 16:16:42 +0100
committerMarcell Meszaros2024-02-18 16:16:42 +0100
commit954de98b9e5898c2b188a674cf3c86c3c1139703 (patch)
tree9b01ca839a2a7a53989313a8ed7239be2025f7aa /PKGBUILD
parentdd81f93355e08b0bc6dcca5863da087bd51d8078 (diff)
downloadaur-perl-time-duration-parse.tar.gz
0.16-2: align deps for current upstream reqs, modernize license (SPDX)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 14 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 018b47d36e5e..84436cfc098d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,23 @@
+# Contributor: Marcell Meszaros < marcell.meszaros AT runbox.eu >
+# Contributor: Michał Wojdyła <micwoj9292@gmail.com>
# Contributor: John D Jones III AKA jnbek <jnbek1972 -_AT_- g m a i l -_Dot_- com>
# Generator : CPANPLUS::Dist::Arch 1.32
-pkgname='perl-time-duration-parse'
+_distname='Time-Duration-Parse'
+pkgname="perl-${_distname@L}"
pkgver='0.16'
-pkgrel='1'
+pkgrel='2'
pkgdesc="Parse string that represents time duration"
arch=('any')
-license=('PerlArtistic' 'GPL')
+license=('LicenseRef-GPL-1.0-or-later OR Artistic-1.0-Perl')
options=('!emptydirs')
-depends=('perl-exporter-lite' 'perl-time-duration' 'perl>=5.006')
-makedepends=()
-url='https://metacpan.org/release/Time-Duration-Parse'
-source=('http://search.cpan.org/CPAN/authors/id/N/NE/NEILB/Time-Duration-Parse-0.16.tar.gz')
-md5sums=('c595c3dfcada3e0534867afa25626bfc')
-_distdir="Time-Duration-Parse-0.16"
+depends=('perl')
+checkdepends=('perl-time-duration')
+url="https://metacpan.org/release/$_distname"
+_author='NEILB'
+source=("https://search.cpan.org/CPAN/authors/id/${_author::1}/${_author::2}/$_author/$_distname-$pkgver.tar.gz")
+sha512sums=('947c7ce0a1a013c86b3c9e464e4c56bb0cc98572c3854d9b6ab33e8dac2270982b72efcd5e2601490e5a23104543ac343033f06294eb88282d0473378117faed')
+_distdir="$_distname-$pkgver"
build() {
( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
@@ -38,8 +42,8 @@ check() {
package() {
cd "$srcdir/$_distdir"
make install
-
find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+ install -Dm644 LICENSE* -t "$pkgdir/usr/share/licenses/$pkgname"
}
# Local Variables: