summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAnton Leontiev2014-02-16 19:30:44 +0400
committerAnton Leontiev2015-02-15 07:48:20 +0300
commit35b26a19a8e37b7625a42e733f7a49180ad4f731 (patch)
tree81a4628a4fa193a4bfbdcf21e62a86f246e6e1e6 /PKGBUILD
downloadaur-35b26a19a8e37b7625a42e733f7a49180ad4f731.tar.gz
Initial v1.05-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7db873a32cbe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# CPAN Name : Tree::Binary
+# Contributor: Anton Leontiev <bunder /at/ t-25.ru>
+# Generator : CPANPLUS::Dist::Arch 1.28
+
+pkgname=perl-tree-binary
+pkgver=1.05
+pkgrel=1
+pkgdesc='Perl package for OO binary tree'
+arch=('any')
+url='http://search.cpan.org/dist/Tree-Binary'
+license=('PerlArtistic' 'GPL')
+depends=('perl')
+checkdepends=('perl-test-exception')
+source=(http://search.cpan.org/CPAN/authors/id/R/RS/RSAVAGE/Tree-Binary-1.05.tgz)
+options=(!emptydirs)
+md5sums=('4219fe4109544194e8fd6e5cb2e6b1f6')
+
+build() {
+ cd Tree-Binary-1.05
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd Tree-Binary-1.05
+ make test
+}
+
+package() {
+ cd Tree-Binary-1.05
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}