summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAnton Leontiev2020-03-14 16:22:49 +0300
committerAnton Leontiev2020-03-14 16:22:49 +0300
commit4a9175f82242af0acaeddbf748ff5506c4140eb4 (patch)
tree9f0e50c81396d66abef607063bdc3a0b6c9fbcf7 /PKGBUILD
parentacb06d7b853a91673e2f37e5c4838f55a6f5011a (diff)
downloadaur-4a9175f82242af0acaeddbf748ff5506c4140eb4.tar.gz
Update to v1.08
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3738631b2729..d26df547105a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# CPAN Name : Tree::Binary
-# Contributor: Anton Leontiev <bunder /at/ t-25.ru>
-# Generator : CPANPLUS::Dist::Arch 1.30
+# Contributor: Anton Leontiev <scileont /at/ gmail.com>
+# Generator : CPANPLUS::Dist::Arch 1.32
pkgname=perl-tree-binary
-pkgver=1.06
+pkgver=1.08
pkgrel=1
pkgdesc='Perl package for OO binary tree'
arch=('any')
@@ -11,9 +11,9 @@ url='https://metacpan.org/release/Tree-Binary'
license=('PerlArtistic' 'GPL')
depends=('perl')
checkdepends=('perl-test-exception')
-source=(http://search.cpan.org/CPAN/authors/id/R/RS/RSAVAGE/Tree-Binary-1.06.tgz)
+source=(http://search.cpan.org/CPAN/authors/id/R/RS/RSAVAGE/Tree-Binary-1.08.tgz)
options=(!emptydirs)
-md5sums=('3e7d5dc33b14ddf218bac30861093e12')
+md5sums=('76ac414085486e9104f3ada832c231db')
sanitize() {
unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
@@ -21,20 +21,20 @@ sanitize() {
}
build() {
- cd Tree-Binary-1.06
+ cd Tree-Binary-1.08
sanitize
/usr/bin/perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd Tree-Binary-1.06
+ cd Tree-Binary-1.08
sanitize
make test
}
package() {
- cd Tree-Binary-1.06
+ cd Tree-Binary-1.08
sanitize
make install DESTDIR="$pkgdir"
find "$pkgdir" -name .packlist -o -name perllocal.pod -delete